AppManager Incident - Vendor-5 --- State:Down --- Date:Mon Apr 13 12:15:39 GMT 2026

Incident Report for Statuspage

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 22:18 UTC

Investigating

Vendor-5 --- State:Down --- Date:Mon Apr 13 12:15:39 GMT 2026
Posted Apr 13, 2026 - 12:15 UTC
This incident affected: eSIM Vendors (Vendor-5).